PHP, which is an abbreviation for PHP: Hypertext Preprocessor, is among the most commonly used coding languages available out there. Any website or web-based app written in PHP will run on a given web server on the condition that a PHP module is installed, which makes the language absolutely universal and it’s barely a surprise that there are actually a few million servers that support it and hundreds of millions of PHP-driven websites hosted on them. What makes PHP preferred over HTML is the fact that it enables you to develop a dynamic serving website with tons of features. A PHP-based social network, for example, will serve different content to each user irrespective of the fact that the page URL will stay unchanged. In contrast, HTML websites are static and the content on the pages can be edited only manually. Just like any other piece of software, PHP has several versions and the one that was used while building a certain website must be set up on the web server in order for the site to work flawlessly.
PHP 4 and PHP 5 Support in Cloud Hosting
With our cloud hosting, you’ll be able to choose the PHP version that will be enabled for your hosting account, since different versions are activated on our servers. With only one click, you’ll be able to switch between PHP 4, 5.2, 5.3, 5.4 and 5.5 and whenever a new version is introduced in the future, we’ll include it in the Hepsia hosting Control Panel without removing the older versions. Thus, you will be able to host all the sites that you have built through the years. Unlike many other providers, we won’t force you to update such sites, because a script may be outdated, but this doesn’t mean that it is vulnerable since you may have done modifications to its source code to fix safety breaches. For your convenience, you will even be able to specify a different version of PHP for each site that you host in your web hosting account.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
If you have a site created with an older version of PHP and you have dedicated time and effort on developing it, fixing security breaches and adding page content, you will need to find a web hosting service that can support it, since nearly all hosting suppliers these days offer only the newest version of PHP and drop the older ones. We, on the other hand, have decided to allow you to pick the exact version that your own websites require. Our semi-dedicated servers support multiple versions of PHP 5 and PHP 4, which means that you will be able to run both newer and older scripts without losing any customizations or frittering away time and energy struggling to make your sites compatible with the hosting platform. You can change the current version via the Hepsia hosting Control Panel and such an update will apply to the whole semi-dedicated account, but you’ll also be able to select a different version for each single site that you host in your account by using an .htaccess config file.